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  5. Mounting a File System Times Out

Mounting a File System Times Out

Symptom

When running the mount command to mount the file system to the ECSs, the message timed out is displayed.

Possible Causes

  • Cause 1: The network status is not stable.
  • Cause 2: The network connection is abnormal.
  • Cause 3: The DNS configuration of the ECS is incorrect. As a result, the domain name of the file system cannot be parsed and the mounting fails.
  • For cause 4, if the operating system of the ECS where the file system is to be mounted is Ubuntu18 or a later version, mount the file system in a different way.

Fault Diagnosis

After the network fault is excluded, run the mount command again.

Solution

  • For cause 1 and cause 2, troubleshoot the network.

    Re-mount the file system after the network issue is addressed.

    • If the patch is uninstalled successfully, no further action is required.
    • If the problem persists, see the solution for cause 3.
  • Cause 3: The DNS configuration of the ECS is incorrect. As a result, the domain name of the file system cannot be parsed and the mounting fails.
    1. Check the DNS configuration of the tenant and run the cat /etc/resolv.conf command.
      • If the DNS has not been configured, configure it For details about how to configure the DNS, see Configuring DNS.
      • If the DNS has been configured, run the following command to check whether the DNS is correct:

        nslookup File system domain name

        If the resolved IP address is in network segment 100, the DNS configuration is correct. If the IP address is in another network segment, the DNS configuration is incorrect. In this case, go to 2.

    2. Modify the /etc/resolv.conf configuration file on the ECS, configure the correct tenant DNS, and run vi /etc/resolv.conf to edit the /etc/resolv.conf file. Add the IP address of the DNS server in the front of the existing nameserver configuration. The DNS server IP address is 100.125.4.25. See Figure 1.
      Figure 1 Configuring DNS

      The format is as follows:

      nameserver 100.125.4.25
      • If the configuration succeeds, go to 3.
      • If the configuration fails, run the lsattr /etc/resolv.conf command. If the information shown in Figure 2 is displayed, the file is locked.
        Figure 2 A locked file

        Run the chattr -i/etc/resolv.conf command to unlock the file. After that, re-configure the DNS and go to 3.

    3. Press Esc, input :wq, and press Enter to save the changes and exit the vi editor.
    4. The default DNS of the ECS applied by the user is inherited from the VPC to which the ECS belongs. Therefore, when the ECS restarts, the ECS changes synchronously. For this reason, changing configurations of the ECS does not settle the issue completely. You need to modify configurations in the VPC. Set a correct tenant DNS for the subnet of the VPC to which the ECS belongs, as shown in Figure 3 and Figure 4.
      Figure 3 VPC details
      Figure 4 Modifying the DNS
    5. (Optional) Restart the ECS.
    6. Run the mount command again.
      • If the patch is uninstalled successfully, no further action is required.
      • If the problem persists, see the solution for cause 4.
  • For cause 4, if the operating system of the ECS where the file system is to be mounted is Ubuntu18 or a later version, mount the file system in a different way.
    1. Reconfigure DNS by referring to Configuring DNS.
    2. Check whether the target ECS running Ubuntu18 or a later version is a private image.
      • If yes, go to 4.
      • If no, go to 3.
    3. Convert the public image ECS to a private image.
      1. To create a private image based on an existing ECS, see section "Crating an Image" in the Elastic Cloud Server User Guide.
      2. Use the private image created in 3.a to create an ECS or switch the ECS to the private image created in 3.a by referring to section "Changing the OS" in the Elastic Cloud Server User Guide.
    4. Log in to the ECS and mount the file system again.