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  6. What Should I Do If an Authentication Failure Occurs After I Attempt to Remotely Log In to a Windows ECS?

What Should I Do If an Authentication Failure Occurs After I Attempt to Remotely Log In to a Windows ECS?

Symptom

When a local computer running Windows attempts to set up a remote desktop connection to a Windows ECS using RDP, such as MSTSC, an error occurs. The system displays the possible cause "This could be due to CredSSP encryption oracle remediation."

Figure 1 Failed to set up a remote desktop connection

Possible Causes

Microsoft released a security patch in March 2018, which may affect RDP-based CredSSP connections. As a result, setting up RDP-based connections to ECSs failed. For details, visit Unable to RDP to Virtual Machine: CredSSP Encryption Oracle Remediation.

Solution

Modify the remote desktop connection settings on the Windows ECS. To do so, perform the following operations:

  1. Log in to the ECS.
  2. Click Start in the lower left corner, right-click Computer, and choose Properties from the shortcut menu.
  3. In the navigation pane on the left, choose Remote settings.
  4. Click the Remote tab. In the Remote Desktop pane, select Allow connections from computers running any version of Remote Desktop (less secure).
    Figure 2 Modifying remote desktop connection settings
  5. Click OK.