• Object Storage Service

obs
  1. Help Center
  2. Object Storage Service
  3. Developer Guide (Android SDK)
  4. Related Resources
  5. Compatibility

Compatibility

  • Android version: Android 2.3 or later.
  • Namespace: Incompatible with the package structure of earlier versions (1.5.x). All package names and class names are adjusted to be consistent with those of OBS Java SDK.
  • API function: Incompatible with the APIs of earlier versions (1.5.x). New APIs, consistent with those of OBS Java SDK, are adopted.
  • If Android 4.4 or an earlier version is used, configure HTTP to access OBS.
  • OBS Android SDK 2.x.x is fully upgraded. Its package names, class names, and APIs are adjusted to be consistent with those of OBS Java SDK.